L2TP cu IPSec pe Mikrotik

PPTP este nesecurizat ca atare folosim L2TP folosind IPSec

 

Ne autentificăm pe winbox și intram în meniul PPP (dacă nu avem meniul în stânga îl adăugăm în packages)

Acolo vom da click pe L2TP Server

Alegem autentificare doar mschap2 și dam enable:

L2TP

L2TP

Mergem acum la profiles și modificam profilul default, astfel:

  • Local Address = adresa IP catre local (ether2)
  • Remote Address = IP-ul care va fi alocata echipamentului care va fi prin L2TP autentificat, poate fi statica sau din pool-ul existent

l2tp2

Intrăm la Protocols și setam ca atare (trebuie required la encryption pentru ca altfel nu va merge autentificarea cu windows):

l2tp3

Acum vom adăuga useri, și pentru asta mergem la Secrets în același tab  PPP și dam click pe + și vom face următoarele setări:

  • la Name vom pune numele userului
  • la Password vom pune parola de autentificare
  • la Service vom schimba în l2tp
  • la Profile vom alege profilul default-encription

l2tp4

Acum setam IPSec. L2TP nu are nevoie de IPSec, dar el nu știe sa cripteze de unul singur asa ca vom folosi IPSec pentru asta.

Mergem în IP / IPSEC din Winbox

Dam click pe tab-ul Peers și click pe + pentru a adăuga un nou peer și facem următoarele setări:

  • Address lăsăm 0.0.0.0/0 sa se poată conecta de oriunde.. sau forțăm decât de unde avem nevoie
  • Port lăsăm 500
  • la Secret puneți parole de autentificare IPSec
  • la Exchange Mode schimbați în main l2tp
  • bifam NAT Traversal
  • la Encryption Algorithm schimbam în 3des

l2tp5

 

 


 

Acum setam Windows-ul

 

Mergem în Control Panel

  • după care în Network and Sharing Centre
  • dam click pe Setup a new connection or network 
  • dam click pe Connect to a Workplace
  • dam click pe Use my Internet connection (VPN)

Acum completați:

  • la Internet address puneți IP-ul de WAN al mikrotik (ether1)
  • la Destination name puneți un nume sa știți ce conexiune este (ex: L2TP birou)
  • bifați optiunea Don’t connect now; just set it up…

și dam click pe Next și completați în următoarea fereastra:

  • la User name completați userul stabilit mai devreme (testuser în acest tutorial)
  • la Password puneți parola stabilita în același tab ca și userul
  • bifați Remember this password dacă doriți sa tina minte

și dați Create

Acum Mergem la Network Connections (sau Control Panel / Network and Sharing Centre / Network Connections),

  • aici la tab-ul Security alegem la Type of VPN opțiunea Layer 2 Tunneling Protocol with IPsec (L2TP/IPSec)
  • dam click pe Advanced settings
  • bifam opțiunea Use preshared key for authentication
  • introducem parola care am pus-o mai devreme la IPSec
  • dam click pe OK și ieșim din Advanced settings
  • alegem doar protocolul Microsoft CHAP Version 2 (MS-CHAP v2
  • dam click pe OK si gata

Acum  ne putem conecta de pe Windows și sa fim în aceeasi rețea peste internet

 

In caz ca avem firewall pe mikrotik

Pentru accesul din exterior trebuie sa avem reguli pentru UDP Port 500, UDP Port 1701, si UDP Port 4500 si protocolul 50(ipsec-esp)

Deschidem New Terminal de pe winbox și rulam (modificați sa fie ca la voi):

/ip firewall filter add chain=input protocol=udp dst-port=500,1701,4500 in-interface=ether1-n
et connection-state=new action=accept comment="L2TP cu IPSec"
/ip firewall filter add chain=input protocol=ipsec-esp in-interface=ether1-net connection-sta
te=new action=accept

Aveți grija ca în IP / Firewall / Filter Rules acestea sa fie prima regula

 


Știri Mikrotik:

0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Zi cu cuvintele tale...